Localized CDN issues (Jerusalem data center)

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 13:36 UTC

Monitoring

We have released a hotfix for .il TLDs to mitigate this issue while we await Cloudflare's full resolution of the incident. Thank you for your patience. https://www.cloudflarestatus.com/incidents/vjbxys0gy9bb
Posted Jun 02, 2026 - 22:28 UTC

Investigating

We have received reports of issues with CDN that affects sites hosted in Jerusalem data center. Enabling CDN might cause layout issues on the site. We are investigating the issue.
Posted Jun 02, 2026 - 12:11 UTC
This incident affected: Kinsta CDN.